Next ADF Training
Join Demo Session
Toggle Bar
Responses (1)
  • Accepted Answer

    Monday, March 18 2013, 10:57 PM - #permalink
    The trick is to set the higher values for xmx and xms in ide.conf file.Also you need to set a higher value for xmx and xms in file under your integration weblogic server's default domain.

    I will post a detailed article over here soon..

    # *************************************************************************
    # This script is used to setup the needed environment to be able to start Weblogic Server in this domain.
    # This script initializes the following variables before calling commEnv to set other variables:
    # WL_HOME - The BEA home directory of your WebLogic installation.
    # JAVA_VM - The desired Java VM to use. You can set this environment variable before calling
    # this script to switch between Sun or BEA or just have the default be set.
    # JAVA_HOME - Location of the version of Java used to start WebLogic
    # Server. Depends directly on which JAVA_VM value is set by default or by the environment.
    # USER_MEM_ARGS - The variable to override the standard memory arguments
    # passed to java.
    # PRODUCTION_MODE - The variable that determines whether Weblogic Server is started in production mode.
    # - The variable that determines whether the workshop related settings like the debugger,
    # testconsole or iterativedev should be enabled. ONLY settable using the
    # command-line parameter named production
    # NOTE: Specifying the production command-line param will force
    # the server to start in production mode.
    # Other variables used in this script include:
    # SERVER_NAME - Name of the weblogic server.
    # JAVA_OPTIONS - Java command-line options for running the server. (These
    # will be tagged on to the end of the JAVA_VM and
    # MEM_ARGS)
    # For additional information, refer to "Managing Server Startup and Shutdown for Oracle WebLogic Server"
    # (
    # *************************************************************************

    USER_MEM_ARGS="-Xms1024m -Xmx2048m -XX:MaxPermSize=2048m"


    # If you are getting the 'Low Memory Warning' Message Dialog while running
    # JDeveloper, please increase the -Xmx value below from the default 800M to
    # something greater, like 1024M or 1250M. If after increasing the value,
    # JDeveloper is no longer starting up because it fails to create a virtual
    # machine, then please reduce the modified -Xmx value, or use a 64bit JDK
    # which allows for very very large value for -Xmx.
    AddVMOption -Xmx2048M
    AddVMOption -Xms2048M

    The reply is currently minimized Show
Your Reply